Konfigurasi Cisco Router menjadi Internet Gateway

Pada materi kali ini saya akan membahas bagaimana cara melakukan konfigurasi cisco router agar dapat di fungsikan menjadi router internet gateway pada jaringan komputer, untuk topologi yang akan di gunakan pada materi ini bisa lihat pada gambar di bawah ini :

Pada gambar topologi di atas terdapat sebuah router cisco dengan seri 1841 yang menjadi perantara antara PC dan Internet, router ini yang nantinya akan di fungsikan sebagai router internet gateway agar client yang berada di bawahnya mendapatkan fasilitas internet dari ISP, untuk koneksi antara router ke Internet menggunakan media kabel yang terhubung ke interface fa0/0 dan router ke PC terhubung ke interface fa0/1, baik langsung masuk ke sesi konfigurasi, pada gambar topologi di atas terdapat step by step bagaimana cara melakukan konfigurasi tersebut, dan untuk melakukan konfigurasi ini maka saya akan mengacu pada step by step pada topologi di atas.

  1. Request dhcp client

Konfigurasi pertama ini bertujuan untuk membuat koneksi antara router cisco dengan router ISP dimana dengan cara meminta ip address secara otomatis dari router ISP ke router cisco, konfigurasi ini di sebut dengan request dhcp client, caranya :

Router>enable
Router#configure terminal
Router(config)#interface fa0/0
Router(config-if)#no shutdown
Router(config-if)#ip address dhcp
*Jun 26 07:33:36.571: %DHCP-6-ADDRESS_ASSIGN: Interface FastEthernet0/0 assigned DHCP address 20.20.20.254, mask 255.255.255.0, hostname Router

Jika langkah pertama ini berhasil maka router cisco akan otomatis mendapatkan ip address dari router ISP dan pada tahap ini seharusnya router cisco sudah mendapatkan akses internet dari router ISP, sebelum masuk ke tahap selanjutnya silahkan cek ip dhcp client dan tes ping ke google.com pada router cisco terlebih dahulu, caranya :

Cek IP DHCP Client pada Router Cisco :

Router#sh ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 20.20.20.254 YES DHCP up up
FastEthernet0/1 unassigned YES unset administratively down down
Serial0/0/0 unassigned YES unset administratively down down

Cek ping router ke Google.com

Router#ping google.com
Translating "google.com"...domain server (8.8.8.8) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 216.58.216.110, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 204/204/208 ms

  1. Buat IP Address untuk Interface Fa0/1

Setelah router cisco sudah mendapatkan ip address dari router ISP dan mendapatkan fasilitas internet, maka langkah selanjutnya adalah membuat ip address untuk interface yang mengarah ke sisi client (fa0/1), untuk skript nya dapat di lihat pada skript di bawah ini :

Router(config)#interface fa0/1
Router(config-if)#ip address 30.30.30.1 255.255.255.0
Router(config-if)#no shutdown
  1. Buat DHCP Excluded Address

Untuk langkah ini bersifat opsional namun saya menyarankan untuk tetap melakukan konfigurasi ini terlebih jika router cisco nantinya akan di setting konfigurasi dhcp server, konfigurasi ini bertujuan agar menyimpan ip address dengan range tertentu dan tidak akan di distribusikan oleh layanan dhcp server, caranya :

Router(config)#ip dhcp excluded-address 30.30.30.1 30.30.30.10

Dengan menerapkan cara di atas maka router akan menyimpan ip address dengan range 30.30.30.1 sd 30.30.30.10 dan tidak akan di berikan oleh client pada pasilitas dhcp server.

  1. Buat DHCP Server

Konfigurasi selanjutnya adalah dengan melakukan konfigurasi dhcp server yang bertujuan agar router dapat mendistribusikan ip address otomatis ke client yang terhubung langsung ke router cisco, caranya :

Router(config)#ip dhcp pool IP-Client
Router(dhcp-config)#network 30.30.30.0 255.255.255.0
Router(dhcp-config)#default-router 30.30.30.1
Router(dhcp-config)#dns-server 8.8.8.8
  1. Buat Name-Server & Access List

Fungsi Name-Server adalah sebagai database domain yang terdapat pada jaringan, umumnya name-server ini di isi dengan ip router ISP jika pada materi ini ip router ISP adalah 20.20.20.1 dapat di lihat pada langkah pertama dimana router cisco mendapatkan ip address 20.20.20.254, jika anda kurang yakin silahkan lakukan ping ke ip 20.20.20.1.

Sedangkan access list berfungsi untuk memfilter atau membatasi paket berdasarkan ip address dan di terapkan pada interface, untuk memudahkan pemahaman silahkan lihat pada konfigurasi di bawah ini :

Router(config)#ip name-server 20.20.20.1
Router(config)#access-list 1 permit 30.30.30.0 0.0.0.255

Router membuat sebuah access list dengan nilai 1 dan action permit (ijinkan) untuk ip dengan network 30.30.30.0 dan wildcard 0.0.0.255 (mask 255.255.255.0) dan access list dengan nilai 1 ini yang nantinya akan di panggil saat konfigurasi nat overloding, fungsi ini sebenarnya bertujuan untuk mendefinisikan bahwa network tersebut di ijinkan untuk melewati access list dengan action permit diatas.

  1. Buat NAT Dynamic Overload

Network Address Translation pada cisco terbagi menjadi 2 yaitu static dan dynamic untuk NAT Static bersifat one to one dan Dynamic memiliki beberapa Opsi seperti NAT dengan Pool dan NAT Overload.

Nat Pool umumnya di gunakan untuk teknik loadbalancing sedangkan NAT Overload adalah NAT yang paling sering di gunakan untuk konfigurasi Internet Gateway dengan cara kerja semua request atau permintaan client local yang menuju ke internet akan di berikan ke satu alamat ip global/outside (IP Public) tentu dengan cara ini akan menghemat penggunaan ip public pada sisi ISP.

Untuk melakukan konfigurasi NAT Overload pertama-tama kita harus mendefinisikan interface mana mengarah ke sumber internet (ISP) dengan cara :

Router(config)#ip nat inside source list 1 interface fa0/0 overload

Pada cara di atas bertujuan untuk mendefinisikan interface fa0/0 yang nantinya akan bertugas menjadi interface overload atau jalur utama menuju internet, sedangkan skript source list 1 yakni mengijinkan network yang sudah terdaftar pada access list 1 tersebut untuk menuju ke internet melalui interface fa0/0.

Setelah mendefinisikan interface overload maka selanjutnya adalah mendefinisikan status pada masing-masing interface tersebut pada menu IP NAT dengan cara :

Router(config)#interface fa0/0
Router(config-if)#ip nat outside
Router(config-if)#exit
Router(config)#interface fa0/1
Router(config-if)#ip nat inside

Interface fa0/0 berstatus interface yang akan mengarah ke jalur internet (outside) sedangkan Interface fa0/1 berstatus yang akan mengarah ke sisi client local (inside). pada tahap ini seharusnya konfigurasi internet gateway pada router cisco telah selesai, untuk pengujian dapat di lakukan pada sisi client dengan cara :

  1. Cek IP Address PC
C:\Users\L412>ipconfig

Windows IP Configuration

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::d1cd:
IPv4 Address. . . . . . . . . . . : 30.30.30.11
Subnet Mask . . . . . . . . . . . : 255.255.255
Default Gateway . . . . . . . . . : 30.30.30.1

PC sudah mendapatkan ip address dari router yaitu 30.30.30.11

  1. Cek Ping dari PC ke google.com
C:\Users\L412>ping google.com
Pinging google.com [216.58.216.110] with 32 bytes of da
Reply from 216.58.216.110: bytes=32 time=204ms TTL=34
Reply from 216.58.216.110: bytes=32 time=203ms TTL=34
Reply from 216.58.216.110: bytes=32 time=204ms TTL=34
Reply from 216.58.216.110: bytes=32 time=204ms TTL=34

Mungkin Anda juga menyukai

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *