Konfigurasi IP Address dan DHCP Server pada Router Cisco

Assalamualaikum warohmatulahi wabarokatuh

Pada materi kali ini saya akan membahas bagaimana cara konfigurasi ip address dan dhcp server pada router cisco, bagi anda yang belum mengetahui apa itu ip address dan dhcp server silahkan pelajari terlebih dahulu pada link berikut ini :

Penjelasan IP Address

Penjelasan DHCP Server

Sebelum masuk ke sesi konfigurasi mungkin akan sedikit saya beri penjelasan singkat terkait IP Address dan DHCP Server

Secara garis besar fungsi IP Address adalah untuk memberikan alamat pada sebuah device dalam jaringan komputer, fungsi dari alamat tersebut di gunakan untuk melakukan pertukaran data baik secara local maupun interlocal (internet), sedangkan DHCP Server adalah sebuah konfigurasi pada router yang bertujuan agar router tersebut dapat memberikan ip address otomatis ke setiap device yang terhubung ke jaringan tersebut, dengan melakukan settingan DHCP Server pada router maka client yang terhubung ke jaringan tersebut akan otomatis mendapatkan beberapa fasilitas dari router seperti :

IP Address
Gateway
DNS Server

Baik langsung masuk ke sesi konfigurasi pada router cisco, silahkan buat topologi seperti gambar di bawah ini :

Pada topologi di atas saya menggunakan device

Router = 2911
Switch = 2960

Terlihat pada kabel router yeng mengarah ke switch memiliki indikator titik berwarna merah berbeda dengan switch ke pc yang memiliki indikator titik berwarna hijau, hal ini di sebabkan karna interface pada router defaultnya adalah off (shutdown) berbeda dengan switch yang default interfacenya adalah on (no shutdown)

Langkah pertama yang harus di lakukan ada mengaktifkan interface router yang mengarah ke switch dengan mengetikan script di bawah ini :

//Mengaktifkan Interface g0/0 pada router

Router(config)#interface g0/0

Router(config-if)#no shutdown

Hasil dari perintah tersebut dapat di lihat pada gambar di bawah ini :

Langkah selanjutnya memberikan IP Address pada interface g0/0 yang mengarah ke switch, ketikan perintah berikut ini :

//Menambahkan IP Address pada interface g0/0

Router(config)#interface g0/0

Router(config-if)#ip address 192.168.10.1 255.255.255.0

Untuk melihat hasilnya apakah IP Address yang telah di buat berhasil atau tidak, ketikan perintah berikut ini :

//Menampilkan IP Address pada Interface router

Router(config)#do show ip interface brief

Hasilnya seperti gambar di bawah ini :

Konfigurasi ip address pada router telah selesai, untuk konfigurasi selanjutnya yaitu DHCP Server untuk melakukan konfigurasi ini ada beberapa point yang wajib di penuhi

  1. Pemberian nama pada DHCP Pool
  2. Menentukan Network Address dan subnet mask
  3. Memberikan IP Router (Gateway)
  4. Memberikan DNS-Server (DNS default google)

//Konfigurasi DHCP Server pada router

Router(config)#ip dhcp pool dept1

Router(dhcp-config)#network 192.168.10.0 255.255.255.0

Router(dhcp-config)#default-router 192.168.10.1

Router(dhcp-config)#dns-server 8.8.8.8

Konfigurasi terakhir ini bersifat opsional (boleh di lakukan boleh tidak) pada konfigurasi ini bertujuan untuk memberikan range pada ip address tertentu yang tidak akan di terima oleh client pada jaringan tersebut, sebagai contoh :

Jika pada konfigurasi dhcp server di atas secara default akan memberikan ip address ke setiap client di mulai dari 192.168.10.2 sd 192.168.10.254

Namun saya sebagai administrator hanya akan mengijinkan user menerima ip dhcp di mulai dari 192.168.10.11 sd 192.168.10.254, untuk range ip address 192.168.10.1 sd 192.168.10.10 akan saya save utuk keperluan khusus seperti ip address untuk router, access point ataupun server, sampai sini saya harap anda memahami penjelasan di atas, baik lansung masuk ke sesi konfigurasi :

//Konfigurasi Excluded Address pada cisco

Router(config)#ip dhcp excluded-address 192.168.10.1 192.168.10.10

Sampai sini konfigurasi telah selesai secara keseluruhan, langkah terakhir untuk melakukan uji coba, pada setiap PC di setting DHCP agar dapat merequest dhcp client pada router dhcp server, seperti gambar di bawah ini :

Test ping dari PC ke PC dan PC ke Router

Semoga artikel ini bermanfaat

Mungkin Anda juga menyukai

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *